I ran into a nasty issue today – an issue that I have no problem saying would have been way past my abilities to resolve given my current status as a Ruby Noobie. Thank goodness for team members who are way more knowledgeable than I am! I’ll try to do my best here to set up the environment context that produced the issue and follow the steps we (“we” is used loosely here because I didn’t help much) used to resolve the issue…

 

Overview

I kept getting a error while trying to use RubyMine’s integrated debugger to test some of the changes I made to a Rails controller class. Here’s the full console output from the RubyMine debugger…

 

/Users/kbeckman/.rvm/rubies/ruby-1.9.2-p180/bin/ruby -e $stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) /Users/kbeckman/.rvm/gems/ruby-1.9.2-p180/bin/rspec /Users/kbeckman/<ApplicationDir>/spec/controllers/profile_controller_spec.rb --require teamcity/spec/runner/formatter/teamcity/formatter --format Spec::Runner::Formatter::TeamcityFormatter
Testing started at 9:28 PM ...
/Users/kbeckman/.rvm/gems/ruby-1.9.2-p180/gems/webmock-1.6.2/lib/webmock/rspec.rb:23:in `<top (required)>': undefined method `configure' for Spec::Runner:Module (NoMethodError)
    from /Users/kbeckman/<ApplicationDir>/spec/spec_helper.rb:4:in `require'
    from /Users/kbeckman/<ApplicationDir>/spec/spec_helper.rb:4:in `<top (required)>'
    from /Users/kbeckman/<ApplicationDir>/spec/controllers/profile_controller_spec.rb:1:in `require'
    from /Users/kbeckman/<ApplicationDir>/spec/controllers/profile_controller_spec.rb:1:in `<top (required)>'
    from /Users/kbeckman/.rvm/gems/ruby-1.9.2-p180/gems/rspec-core-2.3.1/lib/rspec/core/configuration.rb:388:in `load'
    from /Users/kbeckman/.rvm/gems/ruby-1.9.2-p180/gems/rspec-core-2.3.1/lib/rspec/core/configuration.rb:388:in `block in load_spec_files'
    from /Users/kbeckman/.rvm/gems/ruby-1.9.2-p180/gems/rspec-core-2.3.1/lib/rspec/core/configuration.rb:388:in `map'
    from /Users/kbeckman/.rvm/gems/ruby-1.9.2-p180/gems/rspec-core-2.3.1/lib/rspec/core/configuration.rb:388:in `load_spec_files'
    from /Users/kbeckman/.rvm/gems/ruby-1.9.2-p180/gems/rspec-core-2.3.1/lib/rspec/core/command_line.rb:18:in `run'
    from /Users/kbeckman/.rvm/gems/ruby-1.9.2-p180/gems/rspec-core-2.3.1/lib/rspec/core/runner.rb:55:in `run_in_process'
    from /Users/kbeckman/.rvm/gems/ruby-1.9.2-p180/gems/rspec-core-2.3.1/lib/rspec/core/runner.rb:46:in `run'
    from /Users/kbeckman/.rvm/gems/ruby-1.9.2-p180/gems/rspec-core-2.3.1/lib/rspec/core/runner.rb:10:in `block in autorun'
Empty test suite.

Process finished with exit code 1

 

Investigation

Below is the /webmock-1.6.2/lib/webmock/rspec.rb where the actual exception was being thrown… And here’s why:

a) On line 4, “RSpec” was defined but “RSpec:Expectations” was undefined and the code ran to line 6.

b) On line 6, “Spec” was defined so the contents of the elsif block were executed where some global RSpec variables are set to whatever webmock thinks they should be. This a technique that dynamic languages use to swap out existing functionality for some entirely different implementation. No need for IoC Containers here!

c) The code continues to execute running over the else block (what we really wanted to have execute) and runs to line 23.

d) On line 23, the code blows up because of “undefined method ‘configure’ for Spec::Runner:Module (NoMethodError)”

 

require 'webmock'

# RSpec 1.x and 2.x compatibility
if defined?(RSpec) && defined?(RSpec::Expectations)
  RSPEC_NAMESPACE = RSPEC_CONFIGURER = RSpec
elsif defined?(Spec)
  RSPEC_NAMESPACE = Spec
  RSPEC_CONFIGURER = Spec::Runner
else  
  begin
    require 'rspec/core'
    require 'rspec/expectations'
    RSPEC_NAMESPACE = RSPEC_CONFIGURER = RSpec
  rescue LoadError
    require 'spec'
    RSPEC_NAMESPACE = Spec
    RSPEC_CONFIGURER = Spec::Runner
  end
end

require 'webmock/rspec/matchers'
  
RSPEC_CONFIGURER.configure { |config|

  config.include WebMock::API
  config.include WebMock::Matchers

  config.after(:each) do
    WebMock.reset!
  end
}

WebMock::AssertionFailure.error_class = RSPEC_NAMESPACE::Expectations::ExpectationNotMetError

 

So why did this happen? It turns out that somewhere in RubyMine, a “Spec::Runner” is defined and it doesn’t have the configure() method that we need. If you look at some of the very first heinous highlight above from the stack trace, you’ll notice that RubyMine is using a --require” and “--formatter” command line arguments. The “--require" argument tells Ruby to load whatever is in that directory. I’m not going to go into all of the details, but it has something to do with output formatting for use with JetBrains’ CI server, TeamCity. Whatever is in that directory is causing our problem by defining a “Spec::Runner” before webmock can load a replacement.

 

Resolution

Fixing the issue required a slight modification to the /webmock-1.6.2/lib/webmock/rspec.rb listed above. Here’s our fully modified file. Please note the heinous highlight… We added a check to determine whether or not the “Spec.configure” method was defined since this was the one that was previously throwing the exception. Now the code evaluates “Spec.configure” as undefined and falls through to execute the else block where webmock successfully sets up its requirements using the “Spec” definition from RSpec instead of whatever was in the teamcity/spec/runner/formatter/teamcity/formatter directory. If you’re curious as to what that was in RubyMine’s internals causing the issue, help yourself with the following command. Please note your RubyMine location might differ from mine…

 

cd ~/applications/RubyMine\ 3.1.1.app/rb
grep -R Spec **

 

require 'webmock'

# RSpec 1.x and 2.x compatibility
if defined?(RSpec) && defined?(RSpec::Expectations)
  RSPEC_NAMESPACE = RSPEC_CONFIGURER = RSpec
elsif defined?(Spec) && defined?(Spec.configure)
  RSPEC_NAMESPACE = Spec
  RSPEC_CONFIGURER = Spec::Runner
else  
  begin
    require 'rspec/core'
    require 'rspec/expectations'
    RSPEC_NAMESPACE = RSPEC_CONFIGURER = RSpec
  rescue LoadError
    require 'spec'
    RSPEC_NAMESPACE = Spec
    RSPEC_CONFIGURER = Spec::Runner
  end
end

require 'webmock/rspec/matchers'
  
RSPEC_CONFIGURER.configure { |config|

  config.include WebMock::API
  config.include WebMock::Matchers

  config.after(:each) do
    WebMock.reset!
  end
}

WebMock::AssertionFailure.error_class = RSPEC_NAMESPACE::Expectations::ExpectationNotMetError

 

So, we’re not quite done yet… We’ve fixed the issue by forcing the setup block in the webmock rspec.rb file to execute, but as soon as we run “bundle install” or “gem update webmock” or any of the other countless ways you could probably update webmock’s code we’ll more than likely get the same issue. To make sure that doesn’t happen, we did the following:

a) Copy the entire /webmock-1.6.2 directory our project was originally sourcing the code from into a customization folder we keep per-project. Our new location for webmock is ../<ApplicationDirectory>/vendor/gems/webmock-1.6.2.

b) Edit the project’s gemfile so webmock is sourced from the edited copy rather than a directory that can be easily overwritten/updated. Our gemfile changes for webmock are below… I’ve commented out the old reference for our new location.

c) Make sure you “$ git commit -a” your webmock source directory…

 

...

group :test do
  #gem 'webmock'
  gem 'webmock', :path => "#{File.expand_path(__FILE__)}/../vendor/gems/webmock-1.6.2"
end

...

 

I hope this helps!!!